summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/Makefile.am
diff options
context:
space:
mode:
authorPedro Vicente Nunes <pvn@hdfgroup.org>2006-07-19 21:47:33 (GMT)
committerPedro Vicente Nunes <pvn@hdfgroup.org>2006-07-19 21:47:33 (GMT)
commit5d8a9053c7c4d7f2fe4807a64156ce8b986c4bd8 (patch)
treeee3accb8c711591703521dde85ebbe44c832eba9 /tools/h5copy/Makefile.am
parentb0379795d52f23d09c7b1d273c3fa71aeba9b356 (diff)
downloadhdf5-5d8a9053c7c4d7f2fe4807a64156ce8b986c4bd8.zip
hdf5-5d8a9053c7c4d7f2fe4807a64156ce8b986c4bd8.tar.gz
hdf5-5d8a9053c7c4d7f2fe4807a64156ce8b986c4bd8.tar.bz2
[svn-r12482] new tool h5copy
it uses the API function H5Gcopy to copy groups and datasets from file to file, read from a command line note: the test script is not finished yet tested on heping, copper, shanti
Diffstat (limited to 'tools/h5copy/Makefile.am')
-rw-r--r--tools/h5copy/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/h5copy/Makefile.am b/tools/h5copy/Makefile.am
new file mode 100644
index 0000000..9632c1b
--- /dev/null
+++ b/tools/h5copy/Makefile.am
@@ -0,0 +1,36 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src and tools/lib directories
+INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+# Test programs and scripts
+TEST_SCRIPT=$(srcdir)/testh5copy.sh
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=h5copy$(EXEEXT)
+
+# This is our main target, the h5copy tool
+bin_PROGRAMS=h5copy
+
+# All programs depend on the hdf5 and h5tools libraries
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+include $(top_srcdir)/config/conclude.am