summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-03-08 19:42:50 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-03-08 19:42:50 (GMT)
commit233d0574aa3d20be5365c959220e59cb77728fed (patch)
treed38a6c759cf5dba29ab999c500b723caba90a6aa /tools/h5diff/CMakeLists.txt
parentfe660a8da4a41719afc009f7fedea8164f948f35 (diff)
downloadhdf5-233d0574aa3d20be5365c959220e59cb77728fed.zip
hdf5-233d0574aa3d20be5365c959220e59cb77728fed.tar.gz
hdf5-233d0574aa3d20be5365c959220e59cb77728fed.tar.bz2
[svn-r20200] Add expected fail condition to memcheck alternate tests.
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 664a308..0a367d9 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -273,6 +273,9 @@ IF (BUILD_TESTING)
# If using memchecker add tests without using scripts
IF (HDF5_ENABLE_USING_MEMCHECKER)
ADD_TEST (NAME H5DIFF-${resultfile} COMMAND $<TARGET_FILE:h5diff> ${ARGN})
+ IF (${resultcode} STREQUAL "1")
+ SET_TESTS_PROPERTIES (H5DIFF-${resultfile} PROPERTIES WILL_FAIL "true")
+ ENDIF (${resultcode} STREQUAL "1")
ELSE (HDF5_ENABLE_USING_MEMCHECKER)
ADD_TEST (
NAME H5DIFF-${resultfile}