summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2012-01-25 21:12:15 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2012-01-25 21:12:15 (GMT)
commit2558bfc5625726cb92294864d7fcb2ecc974c0c3 (patch)
tree7c068688c93428d97d6a3e96444a7b29e4c9e02f /tools/h5diff/CMakeLists.txt
parent012c46e3d0329acf2f1d159fc54ae7092455b8f4 (diff)
downloadhdf5-2558bfc5625726cb92294864d7fcb2ecc974c0c3.zip
hdf5-2558bfc5625726cb92294864d7fcb2ecc974c0c3.tar.gz
hdf5-2558bfc5625726cb92294864d7fcb2ecc974c0c3.tar.bz2
[svn-r21892] Purpose:
Fix for HDFFV-7836 h5diff: displays error stack message for comparing the two dangling symlink with follow-symlinks option Description: While ago, to improve performance, skipping same object checking (h5tools_is_obj_same()) was added. However the checking function doesn't understand about the dangling link and caused the issue. Since handling dangling link code section already implemented, move the checking function after handling dangling-links to address the problem. Test was added and tagged with jira#. Tested: jam (linux32-LE), koala (linux64-LE), ostrich (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE), Windows (32-LE cmake), Cmake (jam)
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index cbb5ed3..1fa1cf3 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -130,6 +130,7 @@ IF (BUILD_TESTING)
h5diff_457.txt
h5diff_458.txt
h5diff_459.txt
+ h5diff_465.txt
h5diff_480.txt
h5diff_481.txt
h5diff_482.txt
@@ -655,6 +656,8 @@ IF (BUILD_TESTING)
h5diff_458.out.err
h5diff_459.out
h5diff_459.out.err
+ h5diff_465.out
+ h5diff_465.out.err
h5diff_480.out
h5diff_480.out.err
h5diff_481.out
@@ -1262,6 +1265,10 @@ ADD_H5_TEST (h5diff_458 2 --follow-symlinks -v --no-dangling-links ${FILE15} $
# dangling link found for ext links (obj to obj). Both dangle links
ADD_H5_TEST (h5diff_459 2 --follow-symlinks -v --no-dangling-links ${FILE15} ${FILE15} /ext_link_noexist1 /ext_link_noexist2)
+# dangling link --follow-symlinks (obj vs obj)
+# (HDFFV-7836)
+ADD_H5_TEST (h5diff_465 1 --follow-symlinks h5diff_danglelinks1.h5 h5diff_danglelinks2.h5 /soft_link1)
+
# ##############################################################################
# # test for group diff recursivly
# ##############################################################################