summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
commit5a4357e4fb0b920c46cae32e446a662dd44ed7f9 (patch)
tree32b62e2f670ca1565689c28ade8f1bdbdb72ee6c /tools/h5diff/CMakeLists.txt
parentc23f3a7ea577b66f103ab06e9310e819c13f5401 (diff)
downloadhdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.zip
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.gz
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.bz2
[svn-r25570] UNDO:Added option to build tools static when building shared libraries. This will prevent 'dll' being appended to the tool name on windows. See HDFFV-8292.
Windows DLL linkage problem because of defines needed. Tested: local linux
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt18
1 files changed, 4 insertions, 14 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 4e38fe1..35c55a4 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -13,15 +13,10 @@ add_executable (h5diff
${HDF5_TOOLS_H5DIFF_SOURCE_DIR}/h5diff_common.c
${HDF5_TOOLS_H5DIFF_SOURCE_DIR}/h5diff_main.c
)
+TARGET_NAMING (h5diff ${LIB_TYPE})
TARGET_C_PROPERTIES (h5diff " " " ")
+target_link_libraries (h5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5diff PROPERTIES FOLDER tools)
-if (ONLY_STATIC_TOOLS)
- TARGET_NAMING (h5diff STATIC)
- target_link_libraries (h5diff ${HDF5_TOOLS_LIB_TARGET}_static ${HDF5_LIB_TARGET}_static)
-else (ONLY_STATIC_TOOLS)
- TARGET_NAMING (h5diff ${LIB_TYPE})
- target_link_libraries (h5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
-endif (ONLY_STATIC_TOOLS)
set (H5_DEP_EXECUTABLES h5diff)
@@ -30,15 +25,10 @@ if (H5_HAVE_PARALLEL)
${HDF5_TOOLS_H5DIFF_SOURCE_DIR}/h5diff_common.c
${HDF5_TOOLS_H5DIFF_SOURCE_DIR}/ph5diff_main.c
)
+ TARGET_NAMING (ph5diff ${LIB_TYPE})
TARGET_C_PROPERTIES (ph5diff " " " ")
+ target_link_libraries (ph5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (ph5diff PROPERTIES FOLDER tools)
- if (ONLY_STATIC_TOOLS)
- TARGET_NAMING (ph5diff STATIC)
- target_link_libraries (ph5diff ${HDF5_TOOLS_LIB_TARGET}_static ${HDF5_LIB_TARGET}_static)
- else (ONLY_STATIC_TOOLS)
- TARGET_NAMING (ph5diff ${LIB_TYPE})
- target_link_libraries (ph5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
- endif (ONLY_STATIC_TOOLS)
endif (H5_HAVE_PARALLEL)
if (BUILD_TESTING)