summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2010-09-20 22:11:50 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2010-09-20 22:11:50 (GMT)
commit04a731513862dca9425ce5cfd34729318aa6154f (patch)
treea23916a49b6acaef1813fd05aec809df56c265f3 /tools/h5diff/CMakeLists.txt
parentd39def2b729600e9bc84581a8dcbfd326286a379 (diff)
downloadhdf5-04a731513862dca9425ce5cfd34729318aa6154f.zip
hdf5-04a731513862dca9425ce5cfd34729318aa6154f.tar.gz
hdf5-04a731513862dca9425ce5cfd34729318aa6154f.tar.bz2
[svn-r19443] Purpose:
Fix for group comparison with exclude-path case. Use relative path. Description: Related to "1890: h5diff excluding object for file comparison via command line" checkins. (r19406) Tested: jam, amani and heiwa
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 1a6d3df..b5a1e5b 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -118,6 +118,7 @@ IF (BUILD_TESTING)
h5diff_481.txt
h5diff_482.txt
h5diff_483.txt
+ h5diff_484.txt
h5diff_50.txt
h5diff_51.txt
h5diff_52.txt
@@ -779,6 +780,9 @@ ADD_H5_TEST (h5diff_482 0 -v --exclude-path "/group1" --exclude-path "/dset1" ${
# Exclude only some different objects. Expect return - diff
ADD_H5_TEST (h5diff_483 1 -v --exclude-path "/group1" ${EXCLUDE_FILE2_1} ${EXCLUDE_FILE2_2})
+# Exclude from group compare
+ADD_H5_TEST (h5diff_484 0 -v --exclude-path "/dset3" ${EXCLUDE_FILE1_1} ${EXCLUDE_FILE1_2} /group1)
+
ENDIF (BUILD_TESTING)