summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2012-01-24 20:39:59 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2012-01-24 20:39:59 (GMT)
commit13ef2d1fbbc50956c1cea1d28462a974c8e036a6 (patch)
tree6b2022fd5ed84e87b1ad9918b6a66fd5de74f7a6 /tools/h5diff/CMakeLists.txt
parent06f7971a13a5e026a4711a7408319840456a1541 (diff)
downloadhdf5-13ef2d1fbbc50956c1cea1d28462a974c8e036a6.zip
hdf5-13ef2d1fbbc50956c1cea1d28462a974c8e036a6.tar.gz
hdf5-13ef2d1fbbc50956c1cea1d28462a974c8e036a6.tar.bz2
[svn-r21890] Purpose:
Fix for HDFFV-7836 h5diff: displays error stack message for comparing the two dangling symlink with follow-symlinks option Description: While ago, to improve performance, skipping same object checking (h5tools_is_obj_same()) was added. However the checking function doesn't understand about the dangling link and caused the issue. Since handling dangling link code section already implemented, move the checking function after handling dangling-links to address the problem. Test was added and tagged with jira#. Tested: jam (linux32-LE), koala (linux64-LE), ostrich (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE), Windows (32-LE cmake), Cmake (jam)
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index cbb5ed3..1fa1cf3 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -130,6 +130,7 @@ IF (BUILD_TESTING)
h5diff_457.txt
h5diff_458.txt
h5diff_459.txt
+ h5diff_465.txt
h5diff_480.txt
h5diff_481.txt
h5diff_482.txt
@@ -655,6 +656,8 @@ IF (BUILD_TESTING)
h5diff_458.out.err
h5diff_459.out
h5diff_459.out.err
+ h5diff_465.out
+ h5diff_465.out.err
h5diff_480.out
h5diff_480.out.err
h5diff_481.out
@@ -1262,6 +1265,10 @@ ADD_H5_TEST (h5diff_458 2 --follow-symlinks -v --no-dangling-links ${FILE15} $
# dangling link found for ext links (obj to obj). Both dangle links
ADD_H5_TEST (h5diff_459 2 --follow-symlinks -v --no-dangling-links ${FILE15} ${FILE15} /ext_link_noexist1 /ext_link_noexist2)
+# dangling link --follow-symlinks (obj vs obj)
+# (HDFFV-7836)
+ADD_H5_TEST (h5diff_465 1 --follow-symlinks h5diff_danglelinks1.h5 h5diff_danglelinks2.h5 /soft_link1)
+
# ##############################################################################
# # test for group diff recursivly
# ##############################################################################