summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
commit336a7430689b067d2ad4632988d534812a08c8de (patch)
tree7e08511924f2ae7b3dfd68df7d7ac059eac7552c /tools/h5diff/CMakeLists.txt
parent01553cb8f7dca506522b4349043348cccecc318e (diff)
downloadhdf5-336a7430689b067d2ad4632988d534812a08c8de.zip
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.gz
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.bz2
[svn-r22405] HDFFV-8018: add INSTALL commands for packaging the pdb files for windows when configured with RelWithDebInfo
Tested: local linux and Windows
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 4ac4477..4f46541 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -1451,6 +1451,9 @@ ENDIF (BUILD_TESTING)
#-----------------------------------------------------------------------------
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------
+
+INSTALL_PROGRAM_PDB (h5diff ${HDF5_INSTALL_BIN_DIR}/tools toolsapplications)
+
INSTALL (
TARGETS
h5diff
@@ -1461,6 +1464,9 @@ INSTALL (
)
IF (H5_HAVE_PARALLEL)
+
+ INSTALL_PROGRAM_PDB (ph5diff ${HDF5_INSTALL_BIN_DIR}/tools toolsapplications)
+
INSTALL (
TARGETS
ph5diff