summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2011-09-16 19:29:03 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2011-09-16 19:29:03 (GMT)
commit86faf0b30252ff752420010fce5a12b0498a2b04 (patch)
treee51f37c642e5402e2db78205d93930385857912e /tools/h5diff/CMakeLists.txt
parent35d9b3462131ec2287fc7e74c07584ed0d771067 (diff)
downloadhdf5-86faf0b30252ff752420010fce5a12b0498a2b04.zip
hdf5-86faf0b30252ff752420010fce5a12b0498a2b04.tar.gz
hdf5-86faf0b30252ff752420010fce5a12b0498a2b04.tar.bz2
[svn-r21396] Purpose:
HDFFV-7693 - h5diff produces different behavior between versions: 1.8.3 and 1.8.6 Description: There were two issues on this. One was not displaying all the comparable objects if non-comparable object/attribute exist and compared before comparables ones. This issue occurred after 1.8.4 release. This is the issue from user. The other issue was not displaying all the comparable attributes, if non-comparable object/attribute exist and compared ahead. This issue were exist even before 1.8.4 release. So it's possible some attribute comparison may have not displayed correctly in the past, if non-comparable data were exist in common object. Fixed h5diff to display all the comparable object and attribute regardless of non-comparables. Tested: jam (linux32-LE), koala (linux64-LE), heiwa (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE), Cmake (jam, Windows)
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 12dc388..9f45d6a 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -79,6 +79,9 @@ IF (BUILD_TESTING)
h5diff_206.txt
h5diff_207.txt
h5diff_208.txt
+ h5diff_220.txt
+ h5diff_221.txt
+ h5diff_222.txt
h5diff_21.txt
h5diff_22.txt
h5diff_23.txt
@@ -248,6 +251,8 @@ IF (BUILD_TESTING)
h5diff_attr_v_level2.h5
compounds_array_vlen1.h5
compounds_array_vlen2.h5
+ non_comparables1.h5
+ non_comparables2.h5
)
FOREACH (txt_file ${HDF5_REFERENCE_FILES})
@@ -551,6 +556,12 @@ IF (BUILD_TESTING)
h5diff_207.out.err
h5diff_208.out
h5diff_208.out.err
+ h5diff_220.out
+ h5diff_220.out.err
+ h5diff_221.out
+ h5diff_221.out.err
+ h5diff_222.out
+ h5diff_222.out.err
h5diff_21.out
h5diff_21.out.err
h5diff_22.out
@@ -1115,6 +1126,18 @@ ADD_H5_TEST (h5diff_207 0 -c ${FILE2} ${FILE2} g2/dset8 g2/dset9)
# not comparable in dataspace of zero dimension size
ADD_H5_TEST (h5diff_208 0 -c ${FILE19} ${FILE20})
+# non-comparable dataset with comparable attribute, and other comparable datasets.
+# All the rest comparables should display differences.
+ADD_H5_TEST (h5diff_220 1 -c non_comparables1.h5 non_comparables2.h5 /g1)
+
+# comparable dataset with non-comparable attribute and other comparable attributes.
+# All the rest comparables should display differences.
+ADD_H5_TEST (h5diff_221 1 -c non_comparables1.h5 non_comparables2.h5 /g2)
+
+# entire file
+# All the rest comparables should display differences
+ADD_H5_TEST (h5diff_222 1 -c non_comparables1.h5 non_comparables2.h5)
+
# ##############################################################################
# # Links compare without --follow-symlinks nor --no-dangling-links
# ##############################################################################