summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-10-25 16:52:58 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-10-25 16:52:58 (GMT)
commitc5e075851a9e7d2697b1e9ac77e8c18af595f332 (patch)
tree0e5548899989eefe4575667a135dc2b8e5c7945a /tools/h5diff/CMakeLists.txt
parentfa4ab23b9ec53375d13ca43daad741f25215be6f (diff)
downloadhdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.zip
hdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.tar.gz
hdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.tar.bz2
[svn-r21667] Update FOLDER solution option for target properties. Added OPTION command for solution folder and no packaging.
Tested: local linux
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index ec8600f..75e5e25 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -16,6 +16,7 @@ ADD_EXECUTABLE (h5diff
)
TARGET_NAMING (h5diff ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
+SET_TARGET_PROPERTIES (h5diff PROPERTIES FOLDER tools)
SET (H5_DEP_EXECUTABLES h5diff)
@@ -26,6 +27,7 @@ IF (H5_HAVE_PARALLEL)
)
TARGET_NAMING (ph5diff ${LIB_TYPE})
TARGET_LINK_LIBRARIES (ph5diff ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
+ SET_TARGET_PROPERTIES (ph5diff PROPERTIES FOLDER tools)
ENDIF (H5_HAVE_PARALLEL)
set_target_properties(h5diff PROPERTIES FOLDER tools)
@@ -44,6 +46,7 @@ IF (BUILD_TESTING)
ADD_EXECUTABLE (h5diffgentest ${HDF5_TOOLS_H5DIFF_SOURCE_DIR}/h5diffgentest.c)
TARGET_NAMING (h5diffgentest ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5diffgentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
+ SET_TARGET_PROPERTIES (h5diffgentest PROPERTIES FOLDER generator/tools)
#ADD_TEST (NAME h5diffgentest COMMAND $<TARGET_FILE:h5diffgentest>)
ENDIF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)