summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2011-09-02 16:29:45 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2011-09-02 16:29:45 (GMT)
commitcf819259313b0d2af5611ea6cc6db09c75a6abe1 (patch)
tree7399eeb581264be3daa82fce60a2432c8ea68920 /tools/h5diff/CMakeLists.txt
parentcf0db8df74104f6460d3256d73fc08831c6d12ae (diff)
downloadhdf5-cf819259313b0d2af5611ea6cc6db09c75a6abe1.zip
hdf5-cf819259313b0d2af5611ea6cc6db09c75a6abe1.tar.gz
hdf5-cf819259313b0d2af5611ea6cc6db09c75a6abe1.tar.bz2
[svn-r21358] Purpose:
HDFFV-7712 - h5diff: segfault over combinations of complex container types (compound, array, vlen) Description: - Fixed segfault over dataset with container types (array,lven) with multiple nested compound types. (ex: compound->array->compound, compound->vlen->compound) Tested: jam (linux32-LE), koala (linux64-LE), heiwa (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE), Cmake (jam)
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 52a58eb..12dc388 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -158,6 +158,7 @@ IF (BUILD_TESTING)
h5diff_517.txt
h5diff_518.txt
h5diff_530.txt
+ h5diff_540.txt
h5diff_600.txt
h5diff_601.txt
h5diff_603.txt
@@ -245,6 +246,8 @@ IF (BUILD_TESTING)
h5diff_comp_vl_strs.h5
h5diff_attr_v_level1.h5
h5diff_attr_v_level2.h5
+ compounds_array_vlen1.h5
+ compounds_array_vlen2.h5
)
FOREACH (txt_file ${HDF5_REFERENCE_FILES})
@@ -477,6 +480,9 @@ IF (BUILD_TESTING)
SET (EXCLUDE_FILE2_2 h5diff_exclude2-2.h5)
# compound type with multiple vlen string types
SET (COMP_VL_STRS_FILE h5diff_comp_vl_strs.h5)
+ # container types (array,vlen) with multiple nested compound types
+ SET (COMPS_ARRAY_VLEN_FILE1 compounds_array_vlen1.h5)
+ SET (COMPS_ARRAY_VLEN_FILE2 compounds_array_vlen2.h5)
# attrs with verbose option level
SET (ATTR_VERBOSE_LEVEL_FILE1 h5diff_attr_v_level1.h5)
SET (ATTR_VERBOSE_LEVEL_FILE2 h5diff_attr_v_level2.h5)
@@ -703,6 +709,8 @@ IF (BUILD_TESTING)
h5diff_518.out.err
h5diff_530.out
h5diff_530.out.err
+ h5diff_540.out
+ h5diff_540.out.err
h5diff_600.out
h5diff_600.out.err
h5diff_601.out
@@ -1303,6 +1311,12 @@ ADD_H5_TEST (h5diff_484 0 -v --exclude-path "/dset3" ${EXCLUDE_FILE1_1} ${EXCLUD
ADD_H5_TEST (h5diff_530 0 -v ${COMP_VL_STRS_FILE} ${COMP_VL_STRS_FILE} /group /group_copy)
# ##############################################################################
+# # Test container types (array,vlen) with multiple nested compound types
+# # Complex compound types in dataset and attribute
+# ##############################################################################
+ADD_H5_TEST (h5diff_540 1 -v ${COMPS_ARRAY_VLEN_FILE1} ${COMPS_ARRAY_VLEN_FILE2})
+
+# ##############################################################################
# # Test mutually exclusive options
# ##############################################################################
#