summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2011-10-24 21:50:13 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2011-10-24 21:50:13 (GMT)
commite54d15a26ca33a093730861b517604b9305faf67 (patch)
tree2f753d7c84b9d656a6228b9c2c8f499f0f51d447 /tools/h5diff/CMakeLists.txt
parent1dcc75407eb48ebe0ffa3ff35087bbcb4a96c3a7 (diff)
downloadhdf5-e54d15a26ca33a093730861b517604b9305faf67.zip
hdf5-e54d15a26ca33a093730861b517604b9305faf67.tar.gz
hdf5-e54d15a26ca33a093730861b517604b9305faf67.tar.bz2
[svn-r21658] Purpose:
HDFFV-7770 - h5diff segmentation fault on JPSS files Description: Fixed segfault over non-comparable attribute with different dimention or rank, along with '-c' option to display details. Tested: jam (linux32-LE), koala (linux64-LE), heiwa (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE), Windows, Cmake
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index 9f45d6a..866102b 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -1131,6 +1131,7 @@ ADD_H5_TEST (h5diff_208 0 -c ${FILE19} ${FILE20})
ADD_H5_TEST (h5diff_220 1 -c non_comparables1.h5 non_comparables2.h5 /g1)
# comparable dataset with non-comparable attribute and other comparable attributes.
+# Also test non-compatible attributes with different type, dimention, rank.
# All the rest comparables should display differences.
ADD_H5_TEST (h5diff_221 1 -c non_comparables1.h5 non_comparables2.h5 /g2)