summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2010-09-16 23:58:35 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2010-09-16 23:58:35 (GMT)
commita436e4120314040990c8050c8376b4fe81b3a29d (patch)
tree21aaf89a2ce40f107f12f4a117d5678c8f85f11f /tools/h5diff/CMakeLists.txt
parenteb7b5b2ceffb9bed00959c4131ce9cfed09628c4 (diff)
downloadhdf5-a436e4120314040990c8050c8376b4fe81b3a29d.zip
hdf5-a436e4120314040990c8050c8376b4fe81b3a29d.tar.gz
hdf5-a436e4120314040990c8050c8376b4fe81b3a29d.tar.bz2
[svn-r19409] Purpose:
Add extra test cases for bug1975 h5diff - support recursive comparison on group when specified as an object. Description: Additional tests for combination of group recursive and --follow-symlinks with multi-linked external links with several files (same name/strucure). Tested: jam, amani, heiwa
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index a22e0e3..924c4ec 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -194,6 +194,10 @@ IF (BUILD_TESTING)
h5diff_danglelinks2.h5
h5diff_grp_recurse1.h5
h5diff_grp_recurse2.h5
+ h5diff_grp_recurse_ext1.h5
+ h5diff_grp_recurse_ext2-1.h5
+ h5diff_grp_recurse_ext2-2.h5
+ h5diff_grp_recurse_ext2-3.h5
h5diff_exclude1-1.h5
h5diff_exclude1-2.h5
h5diff_exclude2-1.h5
@@ -304,6 +308,11 @@ SET (DANGLE_LINK_FILE1 h5diff_danglelinks1.h5)
SET (DANGLE_LINK_FILE2 h5diff_danglelinks2.h5)
SET (GRP_RECURSE_FILE1 h5diff_grp_recurse1.h5)
SET (GRP_RECURSE_FILE2 h5diff_grp_recurse2.h5)
+# group recursive - same structure via external links through files
+SET (GRP_RECURSE1_EXT h5diff_grp_recurse_ext1.h5)
+SET (GRP_RECURSE2_EXT1 h5diff_grp_recurse_ext2-1.h5)
+SET (GRP_RECURSE2_EXT2 h5diff_grp_recurse_ext2-2.h5)
+SET (GRP_RECURSE2_EXT3 h5diff_grp_recurse_ext2-3.h5)
# same structure, same obj name with different value
SET (EXCLUDE_FILE1_1 h5diff_exclude1-1.h5)
SET (EXCLUDE_FILE1_2 h5diff_exclude1-2.h5)
@@ -732,6 +741,18 @@ ADD_H5_TEST (h5diff_512 -v --follow-symlinks ${GRP_RECURSE_FILE1} ${GRP_RECURSE_
ADD_H5_TEST (h5diff_513 -v ${GRP_RECURSE_FILE1} ${GRP_RECURSE_FILE2} /slink_grp10 /slink_grp11)
ADD_H5_TEST (h5diff_514 -v --follow-symlinks ${GRP_RECURSE_FILE1} ${GRP_RECURSE_FILE2} /slink_grp10 /slink_grp11)
+###############################################################################
+# Test for group recursive diff via multi-linked external links
+# With follow-symlinks, file $GRP_RECURSE1_EXT and $GRP_RECURSE2_EXT1 should
+# be same with the external links.
+###############################################################################
+# file vs file
+ADD_H5_TEST (h5diff_515 -v ${GRP_RECURSE1_EXT} ${GRP_RECURSE2_EXT1})
+ADD_H5_TEST (h5diff_516 -v --follow-symlinks ${GRP_RECURSE1_EXT} ${GRP_RECURSE2_EXT1})
+# group vs group
+ADD_H5_TEST (h5diff_517 -v ${GRP_RECURSE1_EXT} ${GRP_RECURSE2_EXT1} /g1)
+ADD_H5_TEST (h5diff_518 -v --follow-symlinks ${GRP_RECURSE1_EXT} ${GRP_RECURSE2_EXT1} /g1)
+
# ##############################################################################
# # Exclude path (--exclude-path)