summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2010-11-02 16:39:42 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2010-11-02 16:39:42 (GMT)
commite45cfcb9ee17bcfd6e777514f0488f67f2521c83 (patch)
tree3301d806f4fa887eff2ee176b4921956f9bc1a11 /tools/h5diff/CMakeLists.txt
parent584735fb9889d89096a245b4a91894b83b6b7d18 (diff)
downloadhdf5-e45cfcb9ee17bcfd6e777514f0488f67f2521c83.zip
hdf5-e45cfcb9ee17bcfd6e777514f0488f67f2521c83.tar.gz
hdf5-e45cfcb9ee17bcfd6e777514f0488f67f2521c83.tar.bz2
[svn-r19712] Purpose:
Fixed h5diff to handle variable-length strings in a compound dataset correctly. Also variable-length string array in a compound dataset. Bug #1989. Description: Garbage values were displayed when h5diff compared variable-length strings (or string array) in a compound type dataset. Tested: jam (linux32-LE), amani (linux64-LE), heiwa (linuxppc64-BE), tejeda (Mac32)
Diffstat (limited to 'tools/h5diff/CMakeLists.txt')
-rw-r--r--tools/h5diff/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/h5diff/CMakeLists.txt b/tools/h5diff/CMakeLists.txt
index a784ae7..b86a804 100644
--- a/tools/h5diff/CMakeLists.txt
+++ b/tools/h5diff/CMakeLists.txt
@@ -147,6 +147,7 @@ IF (BUILD_TESTING)
h5diff_516.txt
h5diff_517.txt
h5diff_518.txt
+ h5diff_530.txt
h5diff_600.txt
h5diff_601.txt
h5diff_603.txt
@@ -209,6 +210,7 @@ IF (BUILD_TESTING)
h5diff_exclude1-2.h5
h5diff_exclude2-1.h5
h5diff_exclude2-2.h5
+ h5diff_comp_vl_strs.h5
)
FOREACH (txt_file ${HDF5_REFERENCE_FILES})
@@ -326,6 +328,8 @@ IF (BUILD_TESTING)
# different structure and obj names
SET (EXCLUDE_FILE2_1 h5diff_exclude2-1.h5)
SET (EXCLUDE_FILE2_2 h5diff_exclude2-2.h5)
+ # compound type with multiple vlen string types
+ SET (COMP_VL_STRS_FILE h5diff_comp_vl_strs.h5)
# Remove any output file left over from previous test run
ADD_TEST (
@@ -540,6 +544,8 @@ IF (BUILD_TESTING)
h5diff_517.out.err
h5diff_518.out
h5diff_518.out.err
+ h5diff_530.out
+ h5diff_530.out.err
h5diff_600.out
h5diff_600.out.err
h5diff_601.out
@@ -1057,6 +1063,11 @@ ADD_H5_TEST (h5diff_483 1 -v --exclude-path "/group1" ${EXCLUDE_FILE2_1} ${EXCLU
# Exclude from group compare
ADD_H5_TEST (h5diff_484 0 -v --exclude-path "/dset3" ${EXCLUDE_FILE1_1} ${EXCLUDE_FILE1_2} /group1)
+# ##############################################################################
+# # diff various multiple vlen and fixed strings in a compound type dataset
+# ##############################################################################
+ADD_H5_TEST (h5diff_530 0 -v ${COMP_VL_STRS_FILE} ${COMP_VL_STRS_FILE})
+
ENDIF (BUILD_TESTING)