summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-06-03 03:46:44 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-06-03 03:46:44 (GMT)
commit15679022628d7bd232c1b6e234fa6b220e15dc12 (patch)
tree31cad799c52c321234183324ee28ea2600748f95 /tools/h5diff/Makefile.am
parenta2217d58c847974b722729d3f3e016d597c70f0c (diff)
downloadhdf5-15679022628d7bd232c1b6e234fa6b220e15dc12.zip
hdf5-15679022628d7bd232c1b6e234fa6b220e15dc12.tar.gz
hdf5-15679022628d7bd232c1b6e234fa6b220e15dc12.tar.bz2
[svn-r10850] Purpose:
Improvement. Description: assign testph5diff.sh to the Parallel test scripts so that it will be tested for the check-p target. Platforms tested: heping pp. Misc. update:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index d975be4..9dbe53a 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -26,10 +26,7 @@ INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# is enabled.
if BUILD_PARALLEL_CONDITIONAL
H5PDIFF=ph5diff
- H5DIFF_SCRIPT=$(srcdir)/testh5diff.sh $(srcdir)/testph5diff.sh
-else
- H5PDIFF=
- H5DIFF_SCRIPT=$(srcdir)/testh5diff.sh
+ TEST_SCRIPT_PARA=$(srcdir)/testph5diff.sh
endif
# Our main target, h5diff
@@ -37,10 +34,10 @@ bin_PROGRAMS=h5diff $(H5PDIFF)
# Test programs and scripts
TEST_PROG=h5difftst
-TEST_SCRIPT=$(H5DIFF_SCRIPT)
+TEST_SCRIPT=$(srcdir)/testh5diff.sh
check_PROGRAMS=$(TEST_PROG)
-check_SCRIPTS=$(TEST_SCRIPT)
+check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
# Source files for the program
h5diff_SOURCES=h5diff_main.c h5diff_common.c