summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-02-16 20:20:40 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-02-16 20:20:40 (GMT)
commit489f234316bee9ad6dcad44aa82e8bb38fd7f807 (patch)
tree3ccbe2815a1027a7737e59406778d9595f3a2970 /tools/h5diff/Makefile.am
parent8ed95c00114dd3f6d9b766664c3bb56aa75f7a4f (diff)
downloadhdf5-489f234316bee9ad6dcad44aa82e8bb38fd7f807.zip
hdf5-489f234316bee9ad6dcad44aa82e8bb38fd7f807.tar.gz
hdf5-489f234316bee9ad6dcad44aa82e8bb38fd7f807.tar.bz2
[svn-r10017] Purpose:
bug fix/new feature. Description: (committing changes made by Leon.) ph5diff now is a real program by itself. It has its own main (ph5diff_main.c). Codes common to h5diff and ph5diff are in h5diff_common.c. Removed the hack that hide failures from testh5diff.sh. Platforms tested: heping(serial, pp), sol (pp), copper(pp). Misc. update:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index afbcd05..68710a1 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -33,8 +33,7 @@ else
endif
# Our main target, h5diff
-bin_PROGRAMS=h5diff
-bin_SCRIPTS=$(H5PDIFF)
+bin_PROGRAMS=h5diff $(H5PDIFF)
# Test programs and scripts
TEST_PROG=h5difftst
@@ -44,7 +43,8 @@ check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT)
# Source files for the program
-h5diff_SOURCES=h5diff_main.c
+h5diff_SOURCES=h5diff_main.c h5diff_common.c
+ph5diff_SOURCES=ph5diff_main.c h5diff_common.c
h5difftst_SOURCES=testh5diff_main.c testh5diff_attr.c \
testh5diff_basic.c testh5diff_dset.c testh5diff_util.c
@@ -55,8 +55,5 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
# be copied to the testfiles/ directory if update is required
MOSTLYCLEANFILES=*.h5
-ph5diff: h5diff
- @$(CP) $? $@
-
include $(top_srcdir)/config/conclude.am