summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-12-13 21:55:57 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-12-13 21:55:57 (GMT)
commit7a4780e0def60568adb29e8cdcc6c25f253dd787 (patch)
tree7ea89e2756a45dddeb678217b6362a1bf94ecb46 /tools/h5diff/Makefile.am
parentfde99876a3b57f06f37d14727508975712667b5d (diff)
downloadhdf5-7a4780e0def60568adb29e8cdcc6c25f253dd787.zip
hdf5-7a4780e0def60568adb29e8cdcc6c25f253dd787.tar.gz
hdf5-7a4780e0def60568adb29e8cdcc6c25f253dd787.tar.bz2
[svn-r11792] Purpose:
Makefile fix Description: The h5diff parallel test script depends on the serial test script. Added this dependency. Solution: Used SCRIPT_DEPEND variable. Also added ph5diff (when it is compiled). Platforms tested: mir
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index fc2a08d..2d5ed69 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -38,7 +38,8 @@ TEST_SCRIPT=$(srcdir)/testh5diff.sh
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
-SCRIPT_DEPEND=h5diff$(EXEEXT)
+# The parallel test script testph5diff.sh actually depends on testh5diff.sh.
+SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) $(srcdir)/testh5diff.sh
# Source files for the program
h5diff_SOURCES=h5diff_main.c h5diff_common.c