summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-02-03 21:03:24 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-02-03 21:03:24 (GMT)
commit51863989304a051ac6306c8c49c34d70a4cf992e (patch)
tree477f958ad96ec7ef965113c3b007e13e6dfbee4c /tools/h5diff/Makefile.am
parent0b332ace5e6a94c1238b99268675a9ba840215c0 (diff)
downloadhdf5-51863989304a051ac6306c8c49c34d70a4cf992e.zip
hdf5-51863989304a051ac6306c8c49c34d70a4cf992e.tar.gz
hdf5-51863989304a051ac6306c8c49c34d70a4cf992e.tar.bz2
[svn-r9929] Purpose:
Features Description: Added the option to build ph5diff and run testphdf5.sh when parallel mode is enabled. Platforms tested: tested in heping, both serial and parallel. Misc. update:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index ea4fa49..4480277 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -22,12 +22,23 @@ include $(top_srcdir)/config/commence.am
# Include src and tools/lib directories
AM_CFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+# Always build and test h5diff but build and test ph5diff only if parallel
+# is enabled.
+if BUILD_PARALLEL_CONDITIONAL
+ H5PDIFF=ph5diff
+ H5DIFF_SCRIPT=$(srcdir)/testh5diff.sh $(srcdir)/testph5diff.sh
+else
+ H5PDIFF=
+ H5DIFF_SCRIPT=$(srcdir)/testh5diff.sh
+endif
+
# Our main target, h5diff
bin_PROGRAMS=h5diff
+bin_SCRIPTS=$(H5PDIFF)
# Test programs and scripts
TEST_PROG=h5difftst
-TEST_SCRIPT=$(srcdir)/testh5diff.sh
+TEST_SCRIPT=$(H5DIFF_SCRIPT)
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT)
@@ -44,5 +55,8 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
# be copied to the testfiles/ directory if update is required
MOSTLYCLEANFILES=*.h5
+ph5diff: h5diff
+ @$(CP) $? $@
+
include $(top_srcdir)/config/conclude.am