summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-06-12 22:04:41 (GMT)
committerlrknox <lrknox>2017-06-12 22:04:41 (GMT)
commit16e0eb3c5238d358e0db3d6b3d83ac14b5550e92 (patch)
treeb530678f2a6ce550a06ae4a69e187af22aa599f4 /tools/h5diff/Makefile.am
parent62142b4cbc374e832accf687b25c8146eaab3952 (diff)
downloadhdf5-16e0eb3c5238d358e0db3d6b3d83ac14b5550e92.zip
hdf5-16e0eb3c5238d358e0db3d6b3d83ac14b5550e92.tar.gz
hdf5-16e0eb3c5238d358e0db3d6b3d83ac14b5550e92.tar.bz2
Moved libdynlib* plugin test libraries to noist_LT_LIBRARIES with added
flag '-rpath /nowhere' to stop them being installed while keeping them from linking with libhdf5, etc. Incremented version to 1.8.19-pre1 and ran bin/release to create tar and zip files for testing.
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index 337261a..4b153d5 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -58,14 +58,12 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
if HAVE_SHARED_CONDITIONAL
# Build it as shared library if configure is enabled for shared library.
- dyn_LTLIBRARIES=libdynlibdiff.la
+ noinst_LTLIBRARIES=libdynlibdiff.la
libdynlibdiff_la_SOURCES=dynlib_diff.c
- libdynlibdiff_la_LDFLAGS = -avoid-version -module -shared -export-dynamic
+ libdynlibdiff_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -rpath /nowhere
libdynlibdiff.la: $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_DEPENDENCIES) $(EXTRA_libdynlibdiff_la_DEPENDENCIES)
$(AM_V_CCLD)$(libdynlibdiff_la_LINK) $(am_libdynlibdiff_la_rpath) $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_LIBADD)
-#install-exec-hook:
-# $(RM) $(DESTDIR)$(libdir)/*dynlib*
endif
# Temporary files. *.h5 are generated by h5diff. They should