summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-30 23:42:39 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-30 23:42:39 (GMT)
commit66af6dce17787f70e7bded57fdc63b1006ade754 (patch)
treeeb9ecc21bd4c265448324f9e192efac02fd841d8 /tools/h5diff/Makefile.am
parent70ddbda208079d6597e453b510f9bfa9320cf0bf (diff)
downloadhdf5-66af6dce17787f70e7bded57fdc63b1006ade754.zip
hdf5-66af6dce17787f70e7bded57fdc63b1006ade754.tar.gz
hdf5-66af6dce17787f70e7bded57fdc63b1006ade754.tar.bz2
[svn-r11319] Purpose:
Bug fixes Description: This checkin fixes an occasional error on kelgia on sol during distclean. It also causes test scripts to depend properly on the programs they're supposed to be testing. Solution: The kelgia bug was due to some files being cleaned by automake and manually. Removed the manual cleaning in src/Makefile.am. Test script dependencies now need to be specified manually, since the makefile can't guess what they test from their name. Currently all test scripts in a given directory have a single list of dependencies--this was easy and seems to be sufficient. These dependencies are listed in the SCRIPT_DEPEND variable in the Makefile.am. Platforms tested: heping, mir, modi4, sol Misc. update:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index 865d9af..fc2a08d 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -38,6 +38,7 @@ TEST_SCRIPT=$(srcdir)/testh5diff.sh
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
+SCRIPT_DEPEND=h5diff$(EXEEXT)
# Source files for the program
h5diff_SOURCES=h5diff_main.c h5diff_common.c