summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2013-07-18 05:12:27 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2013-07-18 05:12:27 (GMT)
commit3a316cfc638d104045ca22da0d73b0d7121237bc (patch)
treec6b7c10ec5011ccec85df87dd17515c0dcab62a8 /tools/h5diff/Makefile.am
parent0bdce69c790ca1ea22e434615efa092dd27f42d1 (diff)
downloadhdf5-3a316cfc638d104045ca22da0d73b0d7121237bc.zip
hdf5-3a316cfc638d104045ca22da0d73b0d7121237bc.tar.gz
hdf5-3a316cfc638d104045ca22da0d73b0d7121237bc.tar.bz2
[svn-r23917] Bug fix: HDFFV-8392
tools/h5diff/testh5diff.sh is run in every "make check", even after it has passed in the previous run. The error was in the previous change made to Makefile.am when testh5diff.sh.in was created. The mistake was in the SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) $(srcdir)/testh5diff.sh $(srcdir)/testh5diff.sh no longer existed. It is now generated in the current built directory from $(srcdir)/testh5diff.sh.in (which configure takes care of). I updated the dependance to SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) testh5diff.sh and that fixes the error. Reviewed: HDF5-149 Tested: h5committested.
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index 190c083..05417f5 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -43,7 +43,7 @@ TEST_SCRIPT=testh5diff.sh
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
# The parallel test script testph5diff.sh actually depends on testh5diff.sh.
-SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) $(srcdir)/testh5diff.sh
+SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) testh5diff.sh
# Source files for the program
h5diff_SOURCES=h5diff_main.c h5diff_common.c