summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-04-01 21:04:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-04-01 21:04:06 (GMT)
commitad4154cdc89ddf15691dbfe1c609898ef484808b (patch)
tree19a59cc99175477756b58395d6d57aba7d2687f0 /tools/h5dump/CMakeLists.txt
parent025d90f57313002ddb6ac24dcb034baed1f39012 (diff)
downloadhdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.zip
hdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.tar.gz
hdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.tar.bz2
[svn-r26700] Generators are only built static
Plugin test for disable state does not print error stack and does not print FAILED
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index 9e4ab80c..7658c04 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -27,8 +27,8 @@ if (BUILD_TESTING)
# --------------------------------------------------------------------
if (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
add_executable (h5dumpgentest ${HDF5_TOOLS_H5DUMP_SOURCE_DIR}/h5dumpgentest.c)
- TARGET_NAMING (h5dumpgentest ${LIB_TYPE})
- TARGET_C_PROPERTIES (h5dumpgentest ${LIB_TYPE} " " " ")
+ TARGET_NAMING (h5dumpgentest STATIC)
+ TARGET_C_PROPERTIES (h5dumpgentest STATIC " " " ")
target_link_libraries (h5dumpgentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (h5dumpgentest PROPERTIES FOLDER generator/tools)