summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Kim <jkm@hdfgroup.org>2011-02-15 19:28:48 (GMT)
committerJonathan Kim <jkm@hdfgroup.org>2011-02-15 19:28:48 (GMT)
commitbb294c2b1e729a1af032e305df3422bf264b1c01 (patch)
tree66c2d1cee3cb2546518191f917069dc4232da65e /tools/h5dump/CMakeLists.txt
parent23a80ac554229f2f0163f1a92a02b921bb6c5e29 (diff)
downloadhdf5-bb294c2b1e729a1af032e305df3422bf264b1c01.zip
hdf5-bb294c2b1e729a1af032e305df3422bf264b1c01.tar.gz
hdf5-bb294c2b1e729a1af032e305df3422bf264b1c01.tar.bz2
[svn-r20108] Purpose:
Fixing Bug 2092 - h5dump does not display index for a dataset Description: h5dump skip displaying array indices every certain number when the array type dataset is relatively big. The certain number varies according to the size of each array. This checkin fix the skipping array indices problem. This fix also correct indentation of the dataset data output. Tested: jam (linux32-LE), amani (linux64-LE), heiwa (linuxppc64-BE), tejeda (mac32-LE), linew (solaris-BE)
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index e8e88ad..d8980eb 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -48,6 +48,7 @@ IF (BUILD_TESTING)
tall-5s.ddl
tallfilters.ddl
tarray1.ddl
+ tarray1_big.ddl
tarray2.ddl
tarray3.ddl
tarray4.ddl
@@ -223,6 +224,7 @@ IF (BUILD_TESTING)
taindices.h5
tall.h5
tarray1.h5
+ tarray1_big.h5
tarray2.h5
tarray3.h5
tarray4.h5
@@ -500,6 +502,8 @@ IF (BUILD_TESTING)
tallfilters.out.err
tarray1.out
tarray1.out.err
+ tarray1_big.out
+ tarray1_big.out.err
tarray2.out
tarray2.out.err
tarray3.out
@@ -781,6 +785,8 @@ IF (BUILD_TESTING)
# test for files with array data
ADD_H5_TEST (tarray1 0 tarray1.h5)
+ # # added for bug# 2092 - tarray1_big.h5
+ ADD_H5_TEST (tarray1_big 0 tarray1_big.h5)
ADD_H5_TEST (tarray2 0 tarray2.h5)
ADD_H5_TEST (tarray3 0 tarray3.h5)
ADD_H5_TEST (tarray4 0 tarray4.h5)