summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-20 15:16:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-20 15:16:06 (GMT)
commit456ebba0fbeff3951764acab396ba161297e99ef (patch)
treeddcc9fc08770d657dd15b84cd90fcf6a2e4a7a3a /tools/h5dump/CMakeLists.txt
parent7c31e7873c4e91fdb25b921d0220e9961ef0af7f (diff)
downloadhdf5-456ebba0fbeff3951764acab396ba161297e99ef.zip
hdf5-456ebba0fbeff3951764acab396ba161297e99ef.tar.gz
hdf5-456ebba0fbeff3951764acab396ba161297e99ef.tar.bz2
[svn-r19257] Change Cmake to allow a local zlib header to be used in H5Zdelate module.
Corrected use of "SKIP" message in cmake. Corrections to cmake configuration files (for cmake external projects). Community suggested changes. Tested: local linux
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index 00ff759..04d246c 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -326,7 +326,10 @@ IF (BUILD_TESTING)
MACRO (ADD_SKIP_H5_TEST skipresultfile skipresultcode testtype)
IF (${testtype} STREQUAL "SKIP")
- MESSAGE (STATUS "SKIP ${skipresultfile} ${ARGN}")
+ ADD_TEST (
+ NAME H5REPACK-${testname}
+ COMMAND ${CMAKE_COMMAND} -E echo "SKIP ${skipresultfile} ${ARGN}"
+ )
ELSE (${testtype} STREQUAL "SKIP")
ADD_H5_TEST (${skipresultfile} ${skipresultcode} ${ARGN})
ENDIF (${testtype} STREQUAL "SKIP")