summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-05-23 18:31:42 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-05-23 18:31:42 (GMT)
commit588c5107ced043b2fbef5bad6334873d3107722e (patch)
treef4c6c2729b16c89050c5f4ab339257b70ed298c4 /tools/h5dump/CMakeLists.txt
parent58d14b196b9aef988a6593a01a445e62d92ad636 (diff)
downloadhdf5-588c5107ced043b2fbef5bad6334873d3107722e.zip
hdf5-588c5107ced043b2fbef5bad6334873d3107722e.tar.gz
hdf5-588c5107ced043b2fbef5bad6334873d3107722e.tar.bz2
[svn-r22397] Merge trunk changes for HDFFV-7999 and h5dump test script to branch
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index 91e7ec6..daad33f 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -43,6 +43,7 @@ IF (BUILD_TESTING)
# Copy all the HDF5 files from the test directory into the source directory
# --------------------------------------------------------------------
SET (HDF5_REFERENCE_FILES
+ charsets.ddl
filter_fail.ddl
packedbits.ddl
tall-1.ddl
@@ -238,6 +239,7 @@ IF (BUILD_TESTING)
tvlstr.h5.xml
)
SET (HDF5_REFERENCE_TEST_FILES
+ charsets.h5
filter_fail.h5
packedbits.h5
taindices.h5
@@ -674,6 +676,8 @@ IF (BUILD_TESTING)
COMMAND ${CMAKE_COMMAND}
-E remove
h5dump-help.out
+ charsets.out
+ charsets.out.err
filter_fail.out
filter_fail.out.err
packedbits.out
@@ -1056,6 +1060,9 @@ IF (BUILD_TESTING)
# test printing characters in ASCII instead of decimal
ADD_H5_TEST (tchar1 0 --enable-error-stack -r tchar.h5)
+ # test datatypes in ASCII and UTF8
+ ADD_H5_TEST (charsets 0 --enable-error-stack charsets.h5)
+
# rev. 2004
# tests for super block
ADD_H5_TEST (tboot1 0 --enable-error-stack -H -B -d dset tfcontents1.h5)