summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-11 15:13:05 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-11 15:13:05 (GMT)
commitf5148618649e96f83578b0c415f69bb9016782df (patch)
treeccf142d61c74b40b0dcad28b0b872706f1cdfc06 /tools/h5dump/CMakeLists.txt
parentdbe9c9f7dc95080eb1ad08702f880eda6b573ebd (diff)
downloadhdf5-f5148618649e96f83578b0c415f69bb9016782df.zip
hdf5-f5148618649e96f83578b0c415f69bb9016782df.tar.gz
hdf5-f5148618649e96f83578b0c415f69bb9016782df.tar.bz2
HDFFV-8745 merge h5diff attribute fix
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index 3a91e54..f301014 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -97,10 +97,9 @@ endif ()
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------
if (HDF5_EXPORTED_TARGETS)
- if (BUILD_SHARED_LIBS)
- INSTALL_PROGRAM_PDB (h5dump-shared ${HDF5_INSTALL_BIN_DIR} toolsapplications)
- endif ()
- INSTALL_PROGRAM_PDB (h5dump ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+ foreach (exec ${H5_DEP_EXECUTABLES})
+ INSTALL_PROGRAM_PDB (${exec} ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+ endforeach ()
install (
TARGETS