summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-07-12 20:30:30 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-07-12 20:30:30 (GMT)
commit210d04b05f1ea3a172acf531519a36ee39c982b3 (patch)
tree62bb19366bb46b2c417130d10a6e91d1b8b735ae /tools/h5dump/CMakeLists.txt
parent1942f47bcfa0739e97efba02197136e1ecbb4a29 (diff)
downloadhdf5-210d04b05f1ea3a172acf531519a36ee39c982b3.zip
hdf5-210d04b05f1ea3a172acf531519a36ee39c982b3.tar.gz
hdf5-210d04b05f1ea3a172acf531519a36ee39c982b3.tar.bz2
[svn-r22567] HDFFV-7784: add attributes to the list of file contents option for h5dump. This is accomplished by adding an optional value to the option (-n)
Created test and reference files. Tested: local linux with cmake
Diffstat (limited to 'tools/h5dump/CMakeLists.txt')
-rw-r--r--tools/h5dump/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/h5dump/CMakeLists.txt b/tools/h5dump/CMakeLists.txt
index b8a2d4c..88d28c4 100644
--- a/tools/h5dump/CMakeLists.txt
+++ b/tools/h5dump/CMakeLists.txt
@@ -69,6 +69,8 @@ IF (BUILD_TESTING)
${HDF5_TOOLS_SRC_DIR}/testfiles/tattr-2.ddl
${HDF5_TOOLS_SRC_DIR}/testfiles/tattr-3.ddl
${HDF5_TOOLS_SRC_DIR}/testfiles/tattr-4_be.ddl
+ ${HDF5_TOOLS_SRC_DIR}/testfiles/tattrcontents1.ddl
+ ${HDF5_TOOLS_SRC_DIR}/testfiles/tattrcontents2.ddl
${HDF5_TOOLS_SRC_DIR}/testfiles/tattrintsize.ddl
${HDF5_TOOLS_SRC_DIR}/testfiles/tattrreg.ddl
${HDF5_TOOLS_SRC_DIR}/testfiles/tattrregR.ddl
@@ -854,6 +856,10 @@ IF (BUILD_TESTING)
tattr-3.out.err
tattr-4_be.out
tattr-4_be.out.err
+ tattrcontents1.out
+ tattrcontents1.out.err
+ tattrcontents2.out
+ tattrcontents2.out.err
tattrintsize.out
tattrintsize.out.err
tattrreg.out
@@ -1010,6 +1016,10 @@ IF (BUILD_TESTING)
tordercontents1.out.err
tordercontents2.out
tordercontents2.out.err
+ torderlinks1.out
+ torderlinks1.out.err
+ torderlinks2.out
+ torderlinks2.out.err
tperror.out
tperror.out.err
treference.out
@@ -1060,6 +1070,8 @@ IF (BUILD_TESTING)
tvlstr.out.err
tvms.out
tvms.out.err
+ twidedisplay.out
+ twidedisplay.out.err
)
SET_TESTS_PROPERTIES (H5DUMP-clearall-objects PROPERTIES WORKING_DIRECTORY "${PROJECT_BINARY_DIR}/testfiles")
IF (NOT "${last_test}" STREQUAL "")
@@ -1218,6 +1230,8 @@ IF (BUILD_TESTING)
ADD_H5_TEST (tcontents 0 --enable-error-stack -n tfcontents1.h5)
ADD_H5_TEST (tordercontents1 0 --enable-error-stack -n --sort_by=name --sort_order=ascending tfcontents1.h5)
ADD_H5_TEST (tordercontents2 0 --enable-error-stack -n --sort_by=name --sort_order=descending tfcontents1.h5)
+ ADD_H5_TEST (tattrcontents1 0 --enable-error-stack -n 1 --sort_order=ascending tall.h5)
+ ADD_H5_TEST (tattrcontents2 0 --enable-error-stack -n 1 --sort_order=descending tall.h5)
# tests for storage layout
# compact