summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-08-31 18:38:17 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-08-31 18:38:17 (GMT)
commit3c0de7fb0cb1fdcc83bf376be6aead3abcc49e6e (patch)
treeb06170309bdc41e49843a6a7a66b94bb03bb43e5 /tools/h5dump/Makefile.am
parentee3ed7a67ff8a3d8a3ce2dac4e6942724ba33c85 (diff)
downloadhdf5-3c0de7fb0cb1fdcc83bf376be6aead3abcc49e6e.zip
hdf5-3c0de7fb0cb1fdcc83bf376be6aead3abcc49e6e.tar.gz
hdf5-3c0de7fb0cb1fdcc83bf376be6aead3abcc49e6e.tar.bz2
[svn-r17441] Purpose:
Merge from trunk Description: Merged revisions 17228 and 17440 from trunk to 1.8 Specifically, this brings support of --enable-static-exec flag into 1.8 Tested: Manually on jam, linew, smirom, liberty, plus h5committest. Currently, there is no automatic regression test that exists due to portability issues. Behavior is both different and undefined on certain systems (and while 'nm' command seems to exist on all machines, behavior is confirmed to be different on Mac, possibly others). Solution will be to set up some sort of framework in daily tests to build statically, remove shared paths, and verify executables can function.
Diffstat (limited to 'tools/h5dump/Makefile.am')
-rw-r--r--tools/h5dump/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/h5dump/Makefile.am b/tools/h5dump/Makefile.am
index 599c203..992586b 100644
--- a/tools/h5dump/Makefile.am
+++ b/tools/h5dump/Makefile.am
@@ -34,6 +34,9 @@ SCRIPT_DEPEND=h5dump$(EXEEXT)
# Our main target, the h5dump tool.
bin_PROGRAMS=h5dump
+# Add h5dump specific linker flags here
+h5dump_LDFLAGS = $(LT_STATIC_EXEC)
+
# All the programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)