summaryrefslogtreecommitdiffstats
path: root/tools/h5import/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
commit1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3 (patch)
tree1498397d4ed074adb7798ebff8c6df68ddb829d8 /tools/h5import/CMakeLists.txt
parent1f370978b464b2c189194283a96e2794f51754eb (diff)
downloadhdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.zip
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.gz
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.bz2
[svn-r19527] Add clear generated objects commands to test blocks.
Add configurefile command to copy CTestCustom to build folder. Tested: local linux
Diffstat (limited to 'tools/h5import/CMakeLists.txt')
-rw-r--r--tools/h5import/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/h5import/CMakeLists.txt b/tools/h5import/CMakeLists.txt
index 00f6f1f..e2015dc 100644
--- a/tools/h5import/CMakeLists.txt
+++ b/tools/h5import/CMakeLists.txt
@@ -44,6 +44,22 @@ IF (BUILD_TESTING)
##############################################################################
##############################################################################
+ # Remove any output file left over from previous test run
+ ADD_TEST (
+ NAME H5IMPORT-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ binfp64.bin
+ binin8.bin
+ binin8w.bin
+ binin16.bin
+ binin32.bin
+ binuin16.bin
+ binuin32.bin
+ txtin16.txt
+ txtin32.txt
+ )
+
ADD_TEST (NAME h5importtest COMMAND $<TARGET_FILE:h5importtest>)
ENDIF (BUILD_TESTING)