summaryrefslogtreecommitdiffstats
path: root/tools/h5import/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-25 22:33:59 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-25 22:33:59 (GMT)
commit5c549a6345f12a0271b7a44e06169adb20c568c1 (patch)
tree1fb7a7d0b5eef9ae2c12483104af40dd3c47e2aa /tools/h5import/CMakeLists.txt
parent52839cdf69f02c99a4a25f65ec9c21f698ad81a6 (diff)
downloadhdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.zip
hdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.tar.gz
hdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.tar.bz2
[svn-r19300] BZ 1958: Add h5dump xml tests to CMake support
Tetsed: local linux
Diffstat (limited to 'tools/h5import/CMakeLists.txt')
-rw-r--r--tools/h5import/CMakeLists.txt33
1 files changed, 28 insertions, 5 deletions
diff --git a/tools/h5import/CMakeLists.txt b/tools/h5import/CMakeLists.txt
index 8eea2c1..317456c 100644
--- a/tools/h5import/CMakeLists.txt
+++ b/tools/h5import/CMakeLists.txt
@@ -8,7 +8,7 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# --------------------------------------------------------------------
-# Add the h5import and test executables
+# Add the h5import executables
# --------------------------------------------------------------------
ADD_EXECUTABLE (h5import ${HDF5_TOOLS_H5IMPORT_SOURCE_DIR}/h5import.c)
H5_NAMING (h5import)
@@ -26,7 +26,16 @@ TARGET_LINK_LIBRARIES (h5import ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES h5import)
+##############################################################################
+##############################################################################
+### T E S T I N G ###
+##############################################################################
+##############################################################################
+
IF (BUILD_TESTING)
+ # --------------------------------------------------------------------
+ # Add the h5import executables
+ # --------------------------------------------------------------------
ADD_EXECUTABLE (h5importtest ${HDF5_TOOLS_H5IMPORT_SOURCE_DIR}/h5importtest.c)
H5_NAMING (h5importtest)
IF (WIN32)
@@ -40,14 +49,28 @@ IF (BUILD_TESTING)
ENDIF (MSVC)
ENDIF (WIN32)
TARGET_LINK_LIBRARIES (h5importtest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
+
+##############################################################################
+##############################################################################
+### T H E T E S T S M A C R O S ###
+##############################################################################
+##############################################################################
- ADD_TEST (NAME h5importtest COMMAND $<TARGET_FILE:h5importtest>)
+##############################################################################
+##############################################################################
+### T H E T E S T S ###
+##############################################################################
+##############################################################################
- SET (H5_DEP_EXECUTABLES ${H5_DEP_EXECUTABLES}
- h5importtest
- )
+ ADD_TEST (NAME h5importtest COMMAND $<TARGET_FILE:h5importtest>)
ENDIF (BUILD_TESTING)
+##############################################################################
+##############################################################################
+### I N S T A L L A T I O N ###
+##############################################################################
+##############################################################################
+
#-----------------------------------------------------------------------------
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------