summaryrefslogtreecommitdiffstats
path: root/tools/h5import/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-01-30 14:07:18 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-01-30 14:07:18 (GMT)
commitbd0e39e8e02b6ba487cddc462c3905b925aecfa4 (patch)
treeb5a55340773b85c2e5abb0b3a3a7f9ff45c84010 /tools/h5import/Makefile.am
parentaeedf70ccdd657017a3ad06ebf2aafc8fb65e698 (diff)
downloadhdf5-bd0e39e8e02b6ba487cddc462c3905b925aecfa4.zip
hdf5-bd0e39e8e02b6ba487cddc462c3905b925aecfa4.tar.gz
hdf5-bd0e39e8e02b6ba487cddc462c3905b925aecfa4.tar.bz2
[svn-r14470] Purpose: Fixing configure problem on IRIX64.
Description: IRIX64 failed to build tools/h5import, as well as c++/test with szip. This is because IRIX is very picky when it comes to linking libraries, and must be done in specific order. (other UNIXes are not as such, and thus the problem wasn't present). Solution: Rearrange the order in which the libraries are linked on the compiler line by sorting the line that assigns libraries into the LDADD variable in the Makefile.am's of the two respective directories. Tested: IRIX64, kagiso, smirom
Diffstat (limited to 'tools/h5import/Makefile.am')
-rw-r--r--tools/h5import/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/h5import/Makefile.am b/tools/h5import/Makefile.am
index aabc6c4..a88cb36 100644
--- a/tools/h5import/Makefile.am
+++ b/tools/h5import/Makefile.am
@@ -35,6 +35,6 @@ SCRIPT_DEPEND=h5import$(EXEEXT)
bin_PROGRAMS=h5import
# All programs depend on the main hdf5 library and the tools library
-LDADD=$(LIBHDF5) $(LIBH5TOOLS)
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
include $(top_srcdir)/config/conclude.am