summaryrefslogtreecommitdiffstats
path: root/tools/h5import/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
commit6ea31d54b80e8ceaac21a0399117aa4140b919c7 (patch)
tree0ed583989920edefdb876cd94864a52ec5573d29 /tools/h5import/Makefile.am
parent2b6e8e76ad8d0312ba9683deb9d7e28cd1748d29 (diff)
downloadhdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.zip
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.gz
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.bz2
Added options to build tools and tests for HDF5_ 1_8
Diffstat (limited to 'tools/h5import/Makefile.am')
-rw-r--r--tools/h5import/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/h5import/Makefile.am b/tools/h5import/Makefile.am
index 3f75bdc..ed5eb2c 100644
--- a/tools/h5import/Makefile.am
+++ b/tools/h5import/Makefile.am
@@ -22,8 +22,13 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_PROG=h5importtest
-TEST_SCRIPT=h5importtestutil.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5importtest
+ TEST_SCRIPT=h5importtestutil.sh
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_PROGRAMS=$(TEST_PROG)
check_SCRIPT=h5importtestutil.sh