summaryrefslogtreecommitdiffstats
path: root/tools/h5jam/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-25 22:33:59 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-25 22:33:59 (GMT)
commit5c549a6345f12a0271b7a44e06169adb20c568c1 (patch)
tree1fb7a7d0b5eef9ae2c12483104af40dd3c47e2aa /tools/h5jam/CMakeLists.txt
parent52839cdf69f02c99a4a25f65ec9c21f698ad81a6 (diff)
downloadhdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.zip
hdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.tar.gz
hdf5-5c549a6345f12a0271b7a44e06169adb20c568c1.tar.bz2
[svn-r19300] BZ 1958: Add h5dump xml tests to CMake support
Tetsed: local linux
Diffstat (limited to 'tools/h5jam/CMakeLists.txt')
-rw-r--r--tools/h5jam/CMakeLists.txt34
1 files changed, 29 insertions, 5 deletions
diff --git a/tools/h5jam/CMakeLists.txt b/tools/h5jam/CMakeLists.txt
index 166d272..9c1d09d 100644
--- a/tools/h5jam/CMakeLists.txt
+++ b/tools/h5jam/CMakeLists.txt
@@ -8,7 +8,7 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# --------------------------------------------------------------------
-# Add the h5jam and test executables
+# Add the h5jam executables
# --------------------------------------------------------------------
ADD_EXECUTABLE (h5jam ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/h5jam.c)
H5_NAMING (h5jam)
@@ -73,7 +73,16 @@ SET (H5_DEP_EXECUTABLES
h5unjam
)
+##############################################################################
+##############################################################################
+### T E S T I N G ###
+##############################################################################
+##############################################################################
+
IF (BUILD_TESTING)
+ # --------------------------------------------------------------------
+ # Add the h5jam test executables
+ # --------------------------------------------------------------------
IF (NOT BUILD_SHARED_LIBS)
ADD_EXECUTABLE (h5jamgentest ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/h5jamgentest.c)
H5_NAMING (h5jamgentest)
@@ -88,13 +97,28 @@ IF (BUILD_TESTING)
TARGET_LINK_LIBRARIES (h5jamgentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
#ADD_TEST (NAME h5jamgentest COMMAND $<TARGET_FILE:h5jamgentest>)
-
- SET (H5_DEP_EXECUTABLES ${H5_DEP_EXECUTABLES}
- # h5jamgentest
- )
ENDIF (NOT BUILD_SHARED_LIBS)
+
+##############################################################################
+##############################################################################
+### T H E T E S T S M A C R O S ###
+##############################################################################
+##############################################################################
+
+##############################################################################
+##############################################################################
+### T H E T E S T S ###
+##############################################################################
+##############################################################################
+
ENDIF (BUILD_TESTING)
+##############################################################################
+##############################################################################
+### I N S T A L L A T I O N ###
+##############################################################################
+##############################################################################
+
#-----------------------------------------------------------------------------
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------