summaryrefslogtreecommitdiffstats
path: root/tools/h5jam/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-01-04 18:40:26 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-01-04 18:40:26 (GMT)
commit9449cfa3615eadb40d554a1148ca020ac1b0f632 (patch)
treeed9f5207644fcc9ae8b3a828bf104706e1580436 /tools/h5jam/CMakeLists.txt
parent1c7688c77afe630fc6382f994671ff3d5220279a (diff)
downloadhdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.zip
hdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.tar.gz
hdf5-9449cfa3615eadb40d554a1148ca020ac1b0f632.tar.bz2
[svn-r19907] Windows: Correct how fortran links in CRT library. Also correct macro use for checking libtype.
bring r19906 from 1.8 branch
Diffstat (limited to 'tools/h5jam/CMakeLists.txt')
-rw-r--r--tools/h5jam/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/tools/h5jam/CMakeLists.txt b/tools/h5jam/CMakeLists.txt
index 0896363..215dbc8 100644
--- a/tools/h5jam/CMakeLists.txt
+++ b/tools/h5jam/CMakeLists.txt
@@ -11,19 +11,19 @@ INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# Add the h5jam executables
# --------------------------------------------------------------------
ADD_EXECUTABLE (h5jam ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/h5jam.c)
-H5_NAMING (h5jam)
+H5_NAMING (h5jam ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5jam ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
ADD_EXECUTABLE (getub ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/getub.c)
-H5_NAMING (getub)
+H5_NAMING (getub ${LIB_TYPE})
TARGET_LINK_LIBRARIES (getub ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
ADD_EXECUTABLE (tellub ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/tellub.c)
-H5_NAMING (tellub)
+H5_NAMING (tellub ${LIB_TYPE})
TARGET_LINK_LIBRARIES (tellub ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
ADD_EXECUTABLE (h5unjam ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/h5unjam.c)
-H5_NAMING (h5unjam)
+H5_NAMING (h5unjam ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5unjam ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES
@@ -45,7 +45,7 @@ IF (BUILD_TESTING)
# --------------------------------------------------------------------
IF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
ADD_EXECUTABLE (h5jamgentest ${HDF5_TOOLS_H5JAM_SOURCE_DIR}/h5jamgentest.c)
- H5_NAMING (h5jamgentest)
+ H5_NAMING (h5jamgentest ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5jamgentest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
#ADD_TEST (NAME h5jamgentest COMMAND $<TARGET_FILE:h5jamgentest>)