summaryrefslogtreecommitdiffstats
path: root/tools/h5jam/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-11 21:32:22 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-11 21:32:22 (GMT)
commitb96f342722a76cf3861f0d160f71aa3e5c3b7e88 (patch)
tree21808a536b1c38719684bd7bdd21fb325584c29d /tools/h5jam/Makefile.am
parent791146f98a08c90958fe5df3f546dddc7d341271 (diff)
downloadhdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.zip
hdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.tar.gz
hdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.tar.bz2
[svn-r9993] Purpose:
Bug fix Description: Arabica exhibited strange errors when linker found wrong versions of header files. This happened because include directories were given to linker in the wrong order. Solution: Move include directories from AM_CFLAGS variable to INCLUDES variable to put them before CPPFLAGS variable. Trust me, it works. This bug may also have contributed to strange errors on other platforms (kelgia?). Platforms tested: copper, sleipnir, arabica. (h5dump broke while building on arabica, but this happened in a clean checkout, too).
Diffstat (limited to 'tools/h5jam/Makefile.am')
-rw-r--r--tools/h5jam/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/h5jam/Makefile.am b/tools/h5jam/Makefile.am
index 9378cb7..6e54756 100644
--- a/tools/h5jam/Makefile.am
+++ b/tools/h5jam/Makefile.am
@@ -19,7 +19,7 @@
include $(top_srcdir)/config/commence.am
# Include src and tools/lib directories
-AM_CFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
bin_PROGRAMS=h5jam h5unjam
check_PROGRAMS=tellub h5jamgentest getub