summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-08-19 10:54:48 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-08-19 10:54:48 (GMT)
commit291bf2052931b1f117a9cd43ff707437c8b7dd5b (patch)
treea8ef0041744f267b84d48d13f001598befe8a02b /tools/h5ls/CMakeLists.txt
parenteb9fda6709578d16b69dbd8331f22b6073c4654c (diff)
downloadhdf5-291bf2052931b1f117a9cd43ff707437c8b7dd5b.zip
hdf5-291bf2052931b1f117a9cd43ff707437c8b7dd5b.tar.gz
hdf5-291bf2052931b1f117a9cd43ff707437c8b7dd5b.tar.bz2
[svn-r27522] CMake files match those of the trunk but still need to be updated with changes in this branch.
Tested on: NONE (CMake is still broken in this branch)
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 984b36b..4e96db2 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -10,8 +10,8 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SRC_DIR}/lib)
# Add the h5ls executable
#-----------------------------------------------------------------------------
add_executable (h5ls ${HDF5_TOOLS_H5LS_SOURCE_DIR}/h5ls.c)
-TARGET_NAMING (h5ls ${LIB_TYPE})
-TARGET_C_PROPERTIES (h5ls ${LIB_TYPE} " " " ")
+TARGET_NAMING (h5ls STATIC)
+TARGET_C_PROPERTIES (h5ls STATIC " " " ")
target_link_libraries (h5ls ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5ls PROPERTIES FOLDER tools)
@@ -40,8 +40,5 @@ endif (BUILD_TESTING)
install (
TARGETS
h5ls
- RUNTIME DESTINATION
- ${HDF5_INSTALL_BIN_DIR}
- COMPONENT
- toolsapplications
+ RUNTIME DESTINATION ${HDF5_INSTALL_BIN_DIR} COMPONENT toolsapplications
)