summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-10-14 18:51:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-10-14 18:51:00 (GMT)
commit6de1836e477ddfa255812df8325405a741e002f4 (patch)
tree0a1500ba37e175353ca1f626c1fca217ecdbcb8a /tools/h5ls/CMakeLists.txt
parentf0a356a90324e9542b2272df7e695a5a365dbb13 (diff)
parent321db89a65909c02d7279fed7e8b7a3585cde8da (diff)
downloadhdf5-6de1836e477ddfa255812df8325405a741e002f4.zip
hdf5-6de1836e477ddfa255812df8325405a741e002f4.tar.gz
hdf5-6de1836e477ddfa255812df8325405a741e002f4.tar.bz2
Merge pull request #2 in ~BYRN/hdf5_adb from bugfix/HDFFV-10003-examples-project-fails-to-build to develop
* commit '321db89a65909c02d7279fed7e8b7a3585cde8da': Remove test only tools from exports Fix typo Correct typo in variable format Description: Fixed typo that caused daily test failed when --enable-deprecated-symbols is used. Also, removed a commented-out function. Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) with --enable-deprecated-symbols Description: Added test file titerate.cpp. Platform tested: Verified with bin/chkmanifest Description: Removed commented out lines. Platform tested Jam (only comments) Purpose: Fix bug HDFFR-9920 cont. Description: Added new test file titerate.cpp. Fix:HDFFV-9987 With HDF5-1.10 you cannot specify default dataspace for Fortran (H5S_ALL_F) Removed unused H5T_NATIVE_INTEGER_# variables due to NAG fixes. Purpose: Updated documentation Description: Revised class brief description and other comments for up-to-date info. Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test) Purpose: Fix bug HDFFR-9920 cont. Description: Adding user's test revealed a flaw in the fix. Moved CommonFG's functions in Group to H5Location, so that they could be called by objects that can be used to specify a location Also, rearranged many "#include" header files to resolve conflicts. Add support for namespace and add tools to binaries config
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index b6c0141..baa63b1 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -14,6 +14,7 @@ TARGET_NAMING (h5ls STATIC)
TARGET_C_PROPERTIES (h5ls STATIC " " " ")
target_link_libraries (h5ls ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5ls PROPERTIES FOLDER tools)
+set_global_variable (HDF5_UTILS_TO_EXPORT "${HDF5_UTILS_TO_EXPORT};h5ls")
set (H5_DEP_EXECUTABLES
h5ls