summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-03-19 14:26:04 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-03-19 14:26:04 (GMT)
commit19206f5687a4366f077ae47ae8e206f4a972144f (patch)
tree1022864b6b9015dcb035f33775d3fb0da24cddf2 /tools/h5ls/CMakeLists.txt
parentb1a2c642a7105d808f884a27111236dd77df3ce0 (diff)
downloadhdf5-19206f5687a4366f077ae47ae8e206f4a972144f.zip
hdf5-19206f5687a4366f077ae47ae8e206f4a972144f.tar.gz
hdf5-19206f5687a4366f077ae47ae8e206f4a972144f.tar.bz2
[svn-r22088] HDFFV-7957(7958): Correct use of ERROR_STACK for h5dump and tools.
Tested: local linux after week in trunk
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 599202f..0dec21c 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -98,6 +98,7 @@ IF (BUILD_TESTING)
${HDF5_TOOLS_SRC_DIR}/testfiles/tgroup-3.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/thlink-1.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tloop-1.ls
+ ${HDF5_TOOLS_SRC_DIR}/testfiles/tmultifile.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-1.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-2.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-3.ls
@@ -354,6 +355,11 @@ IF (BUILD_TESTING)
# when used file with no dangling links - expected exit code 0
ADD_H5_TEST (thlinks-nodangle-1 0 -w80 --follow-symlinks --no-dangling-links thlink.h5)
+# test for wildcards in filename (does not work with cmake)
+# ADD_H5_TEST (tstarfile 0 -w80 t*link.h5)
+# ADD_H5_TEST (tqmarkfile 0 -w80 t?link.h5)
+ ADD_H5_TEST (tmultifile 0 -w80 thlink.h5 tslink.h5)
+
# tests for hard links
ADD_H5_TEST (thlink-1 0 -w80 thlink.h5)