summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
commitff47a7df1bc78ddf36d247c76abc03e6861b1c01 (patch)
tree78b4786655f00c75616fc894deec00989bb1f724 /tools/h5ls/CMakeLists.txt
parentec5f5c868fb4dad3452db045c627fe258b152cd2 (diff)
downloadhdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.zip
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.gz
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.bz2
[svn-r19362] Move Windows specific compile and link flags to macros
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 1d2589a..ddb0bfe 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -12,16 +12,7 @@ INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
#-----------------------------------------------------------------------------
ADD_EXECUTABLE (h5ls ${HDF5_TOOLS_H5LS_SOURCE_DIR}/h5ls.c)
H5_NAMING (h5ls)
-IF (WIN32)
- IF (MSVC)
- IF (NOT BUILD_SHARED_LIBS)
- SET_TARGET_PROPERTIES (h5ls
- PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
- )
- ENDIF (NOT BUILD_SHARED_LIBS)
- ENDIF (MSVC)
-ENDIF (WIN32)
+TARGET_WIN_PROPERTIES (h5ls)
TARGET_LINK_LIBRARIES (h5ls ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES