summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-11-16 18:40:21 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-11-16 18:40:21 (GMT)
commit0ec9ac12efe8e2ff45b56d0e15779f565ff4d6e5 (patch)
treed3d93f981cbdd3c06a4d04ec4c81c0363fa95c13 /tools/h5ls/CMakeLists.txt
parent1ab76b1117630d2c5cb503163287b7ba08e3d04d (diff)
downloadhdf5-0ec9ac12efe8e2ff45b56d0e15779f565ff4d6e5.zip
hdf5-0ec9ac12efe8e2ff45b56d0e15779f565ff4d6e5.tar.gz
hdf5-0ec9ac12efe8e2ff45b56d0e15779f565ff4d6e5.tar.bz2
[svn-r19793] Revised the valgrind ignore list, added simple execute command tests for when doing a valgrind test of tools that only use a cmake script for testing.
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 149e69f..0e38fc2 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -265,6 +265,13 @@ IF (BUILD_TESTING)
tvldtypes2be.out.err
)
+ # If using memchecker add tests without using scripts
+ IF (HDF5_ENABLE_USING_MEMCHECKER)
+ ADD_TEST (NAME H5LS-help COMMAND h5ls -w80 -h)
+ ADD_TEST (NAME H5LS-tall COMMAND h5ls -w80 tall.h5)
+ ADD_TEST (NAME H5LS-tsoftlinks COMMAND h5ls --follow-symlinks tsoftlinks.h5)
+ ENDIF (HDF5_ENABLE_USING_MEMCHECKER)
+
# test the help syntax
ADD_H5_TEST (help-1 0 -w80 -h)
ADD_H5_TEST (help-2 0 -w80 --help)