summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-11-16 18:22:36 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-11-16 18:22:36 (GMT)
commit7349aa2b68ef7dd1d9eaaf1e03795ae338877bc6 (patch)
treea4efd914872a4f22780d39d9e5ef682ade772f20 /tools/h5ls/CMakeLists.txt
parent186d01285a70848570482c853d00c151323981fa (diff)
downloadhdf5-7349aa2b68ef7dd1d9eaaf1e03795ae338877bc6.zip
hdf5-7349aa2b68ef7dd1d9eaaf1e03795ae338877bc6.tar.gz
hdf5-7349aa2b68ef7dd1d9eaaf1e03795ae338877bc6.tar.bz2
[svn-r19792] Revised the valgrind ignore list, added simple execute command tests for when doing a valgrind test of tools that only use a cmake script for testing.
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 149e69f..0e38fc2 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -265,6 +265,13 @@ IF (BUILD_TESTING)
tvldtypes2be.out.err
)
+ # If using memchecker add tests without using scripts
+ IF (HDF5_ENABLE_USING_MEMCHECKER)
+ ADD_TEST (NAME H5LS-help COMMAND h5ls -w80 -h)
+ ADD_TEST (NAME H5LS-tall COMMAND h5ls -w80 tall.h5)
+ ADD_TEST (NAME H5LS-tsoftlinks COMMAND h5ls --follow-symlinks tsoftlinks.h5)
+ ENDIF (HDF5_ENABLE_USING_MEMCHECKER)
+
# test the help syntax
ADD_H5_TEST (help-1 0 -w80 -h)
ADD_H5_TEST (help-2 0 -w80 --help)