summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-03-15 20:44:51 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-03-15 20:44:51 (GMT)
commit207c05e2e9f1c2844416c19fe5b74b2d71610fd1 (patch)
treec19592659592a26a552c777222be20328becd189 /tools/h5ls/CMakeLists.txt
parent956fde680a35b1fbc19fa5ff1367fcf8eb54c194 (diff)
downloadhdf5-207c05e2e9f1c2844416c19fe5b74b2d71610fd1.zip
hdf5-207c05e2e9f1c2844416c19fe5b74b2d71610fd1.tar.gz
hdf5-207c05e2e9f1c2844416c19fe5b74b2d71610fd1.tar.bz2
[svn-r22075] Add test for multiple files with h5ls and h5dump.
Tested: local linux
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 599202f..0dec21c 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -98,6 +98,7 @@ IF (BUILD_TESTING)
${HDF5_TOOLS_SRC_DIR}/testfiles/tgroup-3.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/thlink-1.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tloop-1.ls
+ ${HDF5_TOOLS_SRC_DIR}/testfiles/tmultifile.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-1.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-2.ls
${HDF5_TOOLS_SRC_DIR}/testfiles/tnestcomp-3.ls
@@ -354,6 +355,11 @@ IF (BUILD_TESTING)
# when used file with no dangling links - expected exit code 0
ADD_H5_TEST (thlinks-nodangle-1 0 -w80 --follow-symlinks --no-dangling-links thlink.h5)
+# test for wildcards in filename (does not work with cmake)
+# ADD_H5_TEST (tstarfile 0 -w80 t*link.h5)
+# ADD_H5_TEST (tqmarkfile 0 -w80 t?link.h5)
+ ADD_H5_TEST (tmultifile 0 -w80 thlink.h5 tslink.h5)
+
# tests for hard links
ADD_H5_TEST (thlink-1 0 -w80 thlink.h5)