summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-02-04 20:35:25 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-02-04 20:35:25 (GMT)
commit89a47692e9d14798dd2e7506a34f74810c1259dc (patch)
treea9fd7dcda8baeca8c611f7f0ea312f6a84a1b73e /tools/h5ls/CMakeLists.txt
parentba13827093c38cb9d87ae87e59d47a34415c88cb (diff)
downloadhdf5-89a47692e9d14798dd2e7506a34f74810c1259dc.zip
hdf5-89a47692e9d14798dd2e7506a34f74810c1259dc.tar.gz
hdf5-89a47692e9d14798dd2e7506a34f74810c1259dc.tar.bz2
[svn-r20044] Fix bz2127 by dynamically allocating storgae for comments.
Tested: local linux
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index 3039682..7db6c7f 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -62,6 +62,7 @@ IF (BUILD_TESTING)
tsoftlinks-5.ls
textlinksrc-nodangle-1.ls
textlinksrc-nodangle-2.ls
+ tgrp_comments.ls
tsoftlinks-nodangle-1.ls
thlinks-nodangle-1.ls
tgroup.ls
@@ -94,6 +95,7 @@ IF (BUILD_TESTING)
textlinksrc.h5
textlinktar.h5
tgroup.h5
+ tgrp_comments.h5
thlink.h5
tloop.h5
tnestedcomp.h5
@@ -210,6 +212,8 @@ IF (BUILD_TESTING)
textlinksrc-6-old.out.err
textlinksrc-7-old.out
textlinksrc-7-old.out.err
+ tgrp_comments.out
+ tgrp_comments.out.err
tsoftlinks-1.out
tsoftlinks-1.out.err
tsoftlinks-2.out
@@ -288,6 +292,9 @@ IF (BUILD_TESTING)
ADD_H5_TEST (tgroup-1 1 -w80 -r -g tgroup.h5)
ADD_H5_TEST (tgroup-2 0 -w80 -g tgroup.h5/g1)
+ # test for files with groups that have long comments
+ ADD_H5_TEST (tgrp_comments 0 -w80 -v -g tgrp_comments.h5/glongcomment)
+
# test for displaying simple space datasets
ADD_H5_TEST (tdset-1 0 -w80 -r -d tdset.h5)