summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-06-14 16:56:58 (GMT)
committerlrknox <lrknox>2017-06-14 17:26:55 (GMT)
commit9a31b0748f94cd00e4fa349796f1ce2893a75fb4 (patch)
treee9568045884fce4c148bd5369e89c469db4eb0c1 /tools/h5ls/Makefile.am
parentc3718a079965bc9d9637780f0961db1c973c1356 (diff)
downloadhdf5-9a31b0748f94cd00e4fa349796f1ce2893a75fb4.zip
hdf5-9a31b0748f94cd00e4fa349796f1ce2893a75fb4.tar.gz
hdf5-9a31b0748f94cd00e4fa349796f1ce2893a75fb4.tar.bz2
Disable building of libdynlib* dynamically loaded plugin test libraries
on CYGWIN. Added known problem entry to RELEASE.txt. Set version for 1.8.19 release. Barbara updated contents of README.txt file.
Diffstat (limited to 'tools/h5ls/Makefile.am')
-rw-r--r--tools/h5ls/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/h5ls/Makefile.am b/tools/h5ls/Makefile.am
index e257fbd..ba9bc4b 100644
--- a/tools/h5ls/Makefile.am
+++ b/tools/h5ls/Makefile.am
@@ -40,14 +40,13 @@ h5ls_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
# All programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+if NOT_UNAME_CYGWIN
if HAVE_SHARED_CONDITIONAL
# Build it as shared library if configure is enabled for shared library.
noinst_LTLIBRARIES=libdynlibls.la
libdynlibls_la_SOURCES=dynlib_ls.c
- libdynlibls_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -rpath /nowhere
-
-libdynlibls.la: $(libdynlibls_la_OBJECTS) $(libdynlibls_la_DEPENDENCIES) $(EXTRA_libdynlibls_la_DEPENDENCIES)
- $(AM_V_CCLD)$(libdynlibls_la_LINK) $(am_libdynlibls_la_rpath) $(libdynlibls_la_OBJECTS) $(libdynlibls_la_LIBADD)
+ libdynlibls_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -rpath /nowhere -no-undefined
+endif
endif
DISTCLEANFILES=h5ls_plugin.sh