summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-20 19:52:41 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-01-20 19:52:41 (GMT)
commit80161447bb08638ef4264208600ba1e0b0fcb57a (patch)
treee0f8f65a67d5cfa2310c4a664948f3b4e0d32a24 /tools/h5repack/CMakeLists.txt
parent77ac7cb908055dd6f5a015207a126c73536685d5 (diff)
downloadhdf5-80161447bb08638ef4264208600ba1e0b0fcb57a.zip
hdf5-80161447bb08638ef4264208600ba1e0b0fcb57a.tar.gz
hdf5-80161447bb08638ef4264208600ba1e0b0fcb57a.tar.bz2
Merfge changes to CMake test options and add sanitizers
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index b108f31..da41b5f 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -125,7 +125,9 @@ if (BUILD_TESTING)
#add_test (NAME h5repackgentest COMMAND ${CMAKE_CROSSCOMPILING_EMULATOR} $<TARGET_FILE:h5repackgentest>)
endif ()
- include (CMakeTests.cmake)
+ if (HDF5_TEST_TOOLS AND HDF5_TEST_SERIAL)
+ include (CMakeTests.cmake)
+ endif ()
endif ()