summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-10-02 20:02:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-10-02 20:02:37 (GMT)
commitd7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd (patch)
tree04d4a355c483f5c68c1d41f6bd2bd3216984fe11 /tools/h5repack/CMakeLists.txt
parent0728ef8352f9b6a6fb697282f31a071a812d0a9e (diff)
downloadhdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.zip
hdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.tar.gz
hdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.tar.bz2
HDFFV-10919 merge external storage repack
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index fb293f1..b108f31 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -112,6 +112,19 @@ if (BUILD_TESTING)
)
endif ()
+# --------------------------------------------------------------------
+# Add the h5repack test executable
+# --------------------------------------------------------------------
+ if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
+ add_executable (h5repackgentest ${HDF5_TOOLS_H5REPACK_SOURCE_DIR}/h5repackgentest.c)
+ target_include_directories (h5repackgentest PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ TARGET_C_PROPERTIES (h5repackgentest STATIC)
+ target_link_libraries (h5repackgentest PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
+ set_target_properties (h5repackgentest PROPERTIES FOLDER generator/tools)
+
+ #add_test (NAME h5repackgentest COMMAND ${CMAKE_CROSSCOMPILING_EMULATOR} $<TARGET_FILE:h5repackgentest>)
+ endif ()
+
include (CMakeTests.cmake)
endif ()