summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-07-15 17:51:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-07-15 17:51:34 (GMT)
commit0dce71a0a30314da545f1f90a26f537c467b043a (patch)
treeb4ba0890463840d8373d93d15cc3f3247595173d /tools/h5repack/CMakeLists.txt
parent2e929c51a5a0d11b849162e0aec020019b6cfb8d (diff)
downloadhdf5-0dce71a0a30314da545f1f90a26f537c467b043a.zip
hdf5-0dce71a0a30314da545f1f90a26f537c467b043a.tar.gz
hdf5-0dce71a0a30314da545f1f90a26f537c467b043a.tar.bz2
[svn-r19074] Added check for no encoding to determine result for test
Tested: Windows
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index cbf40a5..adec48a 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -53,8 +53,13 @@ IF (BUILD_TESTING)
ADD_TEST (NAME testh5repack_detect_szip COMMAND $<TARGET_FILE:testh5repack_detect_szip>)
IF (HDF5_ENABLE_SZIP_SUPPORT)
- SET (passRegex "yes")
- SET_TESTS_PROPERTIES (testh5repack_detect_szip PROPERTIES PASS_REGULAR_EXPRESSION "yes")
+ IF (HDF5_ENABLE_SZIP_ENCODING)
+ SET (passRegex "yes")
+ SET_TESTS_PROPERTIES (testh5repack_detect_szip PROPERTIES PASS_REGULAR_EXPRESSION "yes")
+ ELSE (HDF5_ENABLE_SZIP_ENCODING)
+ SET (passRegex "no")
+ SET_TESTS_PROPERTIES (testh5repack_detect_szip PROPERTIES PASS_REGULAR_EXPRESSION "no")
+ ENDIF (HDF5_ENABLE_SZIP_ENCODING)
ELSE (HDF5_ENABLE_SZIP_SUPPORT)
SET (passRegex "no")
SET_TESTS_PROPERTIES (testh5repack_detect_szip PROPERTIES PASS_REGULAR_EXPRESSION "no")