summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-06 15:04:38 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-06 15:04:38 (GMT)
commit5e2d5978e48924c576745ae97e6ecc7203666bf3 (patch)
tree95f76b4441581a6d54727a090a45eba7545c3333 /tools/h5repack/CMakeLists.txt
parent0de252524dfec1028bdd9241dbd4cca46535b93a (diff)
downloadhdf5-5e2d5978e48924c576745ae97e6ecc7203666bf3.zip
hdf5-5e2d5978e48924c576745ae97e6ecc7203666bf3.tar.gz
hdf5-5e2d5978e48924c576745ae97e6ecc7203666bf3.tar.bz2
[svn-r19181] Added new h5repack test for bug1797 to CMakeLists.txt. Added corrected changes to test script for verbose filters
Tested: local linux
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index 31e4e90..a13ab5b 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -106,6 +106,7 @@ IF (BUILD_TESTING)
SET (FILE15 h5repack_named_dtypes.h5)
SET (FILE16 tfamily%05d.h5) # located in common testfiles folder
SET (FILE_REF h5repack_refs.h5)
+ SET (FILE_ATTR_REF h5repack_attr_refs.h5)
#-- Copy all the HDF5 files from the test directory into the source directory
SET (HDF5_REFERENCE_TEST_FILES
@@ -113,6 +114,7 @@ IF (BUILD_TESTING)
ublock.bin
h5repack.info
h5repack_attr.h5
+ h5repack_attr_refs.h5
h5repack_deflate.h5
h5repack_early.h5
h5repack_ext.h5
@@ -583,8 +585,13 @@ ADD_H5_TEST (committed_dt "TEST" ${FILE15})
# tests family driver (file is located in common testfiles folder, uses TOOLTEST1
#ADD_H5_TEST ( family "FAMILY" ${FILE16})
-# test various references (bug 1814)
+# test various references (bug 1814 and 1726)
ADD_H5_TEST (bug1814 "TEST" ${FILE_REF})
+
+# test attribute with various references (bug 1797)
+# the references in attribute of compund or vlen datatype
+# TODO: include this test when code portion is completed.
+ADD_H5_TEST (bug1797 "SKIP" ${FILE_ATTR_REF})
ENDIF (BUILD_TESTING)