summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-02-25 17:51:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-02-25 17:51:15 (GMT)
commit600bcf0dc3bf984c752737385e0a90ffd29feb38 (patch)
tree8f26c0f31534e92ea8d99029f3500b781a2a9092 /tools/h5repack/CMakeLists.txt
parentb36793344fdcf94f7aedad336e7ef160b05fe5f7 (diff)
downloadhdf5-600bcf0dc3bf984c752737385e0a90ffd29feb38.zip
hdf5-600bcf0dc3bf984c752737385e0a90ffd29feb38.tar.gz
hdf5-600bcf0dc3bf984c752737385e0a90ffd29feb38.tar.bz2
[svn-r20161] Correct test properties for test order
Tested: local linux
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index c6ae2ac..5db4216 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -236,7 +236,9 @@ IF (BUILD_TESTING)
-D "TEST_REFERENCE=${testfilter}"
-P "${HDF5_RESOURCES_DIR}/grepTest.cmake"
)
- SET_TESTS_PROPERTIES (H5REPACK_VERIFY_LAYOUT-${testname} PROPERTIES DEPENDS H5REPACK-${testname})
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (H5REPACK_VERIFY_LAYOUT-${testname} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
SET (last_test "H5REPACK_VERIFY_LAYOUT-${testname}")
ELSE (${resultcode} STREQUAL "0")
IF (${testfilter} STREQUAL "CHUNKED")
@@ -260,8 +262,10 @@ IF (BUILD_TESTING)
-D "TEST_REFERENCE=${testfilter}"
-P "${HDF5_RESOURCES_DIR}/grepTest.cmake"
)
- SET_TESTS_PROPERTIES (H5REPACK_VERIFY_LAYOUT_ALL-${testname} PROPERTIES DEPENDS H5REPACK-${testname})
- SET (last_test "H5REPACK_VERIFY_LAYOUT-${testname}")
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (H5REPACK_VERIFY_LAYOUT_ALL-${testname} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "H5REPACK_VERIFY_LAYOUT_ALL-${testname}")
ENDIF (${resultcode} STREQUAL "0")
ENDIF (${testtype} STREQUAL "SKIP")
ENDMACRO (ADD_H5_VERIFY_TEST)