summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2011-10-25 06:59:10 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2011-10-25 06:59:10 (GMT)
commitfa4ab23b9ec53375d13ca43daad741f25215be6f (patch)
tree6776365ba9adc479e02ff476ab86ba86f1bf6f63 /tools/h5repack/CMakeLists.txt
parente54d15a26ca33a093730861b517604b9305faf67 (diff)
downloadhdf5-fa4ab23b9ec53375d13ca43daad741f25215be6f.zip
hdf5-fa4ab23b9ec53375d13ca43daad741f25215be6f.tar.gz
hdf5-fa4ab23b9ec53375d13ca43daad741f25215be6f.tar.bz2
[svn-r21664] Added solution folders for most of the projects. This still needs some polish - the solution folder assignment should go closer to the target declaration and not all projects are grouped (parallel, c++, fortran, hl, and a few others).
Tested on Windows.
Diffstat (limited to 'tools/h5repack/CMakeLists.txt')
-rw-r--r--tools/h5repack/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/h5repack/CMakeLists.txt b/tools/h5repack/CMakeLists.txt
index b2fb8d3..caa8601 100644
--- a/tools/h5repack/CMakeLists.txt
+++ b/tools/h5repack/CMakeLists.txt
@@ -26,6 +26,8 @@ TARGET_LINK_LIBRARIES (h5repack ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES h5repack)
+set_target_properties(h5repack PROPERTIES FOLDER tools)
+
##############################################################################
##############################################################################
### T E S T I N G ###
@@ -39,10 +41,12 @@ IF (BUILD_TESTING)
ADD_EXECUTABLE (testh5repack_detect_szip ${HDF5_TOOLS_H5REPACK_SOURCE_DIR}/testh5repack_detect_szip.c)
TARGET_NAMING (testh5repack_detect_szip ${LIB_TYPE})
TARGET_LINK_LIBRARIES (testh5repack_detect_szip ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
+ set_target_properties(testh5repack_detect_szip PROPERTIES FOLDER tools)
ADD_EXECUTABLE (h5repacktest ${REPACK_COMMON_SRCS} ${HDF5_TOOLS_H5REPACK_SOURCE_DIR}/h5repacktst.c)
TARGET_NAMING (h5repacktest ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5repacktest ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
+ set_target_properties(h5repacktest PROPERTIES FOLDER tools)
IF (HDF5_TEST_VFD)
SET (VFD_LIST