summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-10-02 20:02:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-10-02 20:02:37 (GMT)
commitd7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd (patch)
tree04d4a355c483f5c68c1d41f6bd2bd3216984fe11 /tools/h5repack/Makefile.am
parent0728ef8352f9b6a6fb697282f31a071a812d0a9e (diff)
downloadhdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.zip
hdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.tar.gz
hdf5-d7b76fdf9d39d98bf4fcf48bf342dcc7b18da3cd.tar.bz2
HDFFV-10919 merge external storage repack
Diffstat (limited to 'tools/h5repack/Makefile.am')
-rw-r--r--tools/h5repack/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/h5repack/Makefile.am b/tools/h5repack/Makefile.am
index dac7aa9..284bca3 100644
--- a/tools/h5repack/Makefile.am
+++ b/tools/h5repack/Makefile.am
@@ -19,12 +19,12 @@
include $(top_srcdir)/config/commence.am
# Include src, test, and tools/lib directories
-AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib -I$(top_srcdir)/tools/h5repack
# Test programs and scripts
if BUILD_TESTS_CONDITIONAL
TEST_SCRIPT=h5repack.sh
-TEST_PROG=h5repacktst
+TEST_PROG=h5repacktst h5repackgentest
noinst_PROGRAMS=testh5repack_detect_szip
if HAVE_SHARED_CONDITIONAL
if USE_PLUGINS_CONDITIONAL
@@ -87,7 +87,8 @@ endif
# Temporary files. *.h5 are generated by h5repack. They should
# copied to the testfiles/ directory if update is required.
-CHECK_CLEANFILES+=*.h5 *.bin testfiles/h5diff_attr1.h5 testfiles/tfamily*.h5
+# *.dat files may be created by h5repackgentest.
+CHECK_CLEANFILES+=*.h5 *.dat *.bin testfiles/h5diff_attr1.h5 testfiles/tfamily*.h5
DISTCLEANFILES=h5repack.sh h5repack_plugin.sh
include $(top_srcdir)/config/conclude.am